FlytrapCare Carnivorous Plant Forums

Sponsored by FlytrapStore.com

Discuss all micropropagation related topics here.

Moderator: Matt

User avatar
By RadRiverOtter
Location: 
Posts:  25
Joined:  Mon Nov 09, 2020 12:43 am
#412449
Does anyone have any clever techniques for either preventing or soaking up excessive condensation in culture vessels after they come out of the pressure cooker.

Does anyone else have this issue?
IMG_28052022_002535_(1080_x_810_pixel).jpg
IMG_28052022_002535_(1080_x_810_pixel).jpg (208.87 KiB) Viewed 5199 times
This seems excessive right?

I used to mop out each vessel individually with sterile paper towel corners and forceps. Now I leave them cracked open in my laminar hood for an hour or so. This just seems like I'm leaving too many opportunities for contamination.
User avatar
By Hendre
Location: 
Posts:  91
Joined:  Sun Mar 29, 2020 2:03 pm
#412462
Can leave them under the hood to cool a bit, usually no issue. I just leave the condensation be, I am not bothered fighting it so long as I can still see into the container. I have noticed those using gelrite get a bit less condensation (I use agar) but that may be anecdotal.
RadRiverOtter liked this
User avatar
By RadRiverOtter
Location: 
Posts:  25
Joined:  Mon Nov 09, 2020 12:43 am
#412541
Hendre wrote:Can leave them under the hood to cool a bit, usually no issue. I just leave the condensation be, I am not bothered fighting it so long as I can still see into the container. I have noticed those using gelrite get a bit less condensation (I use agar) but that may be anecdotal.
I think I must be doing something wrong then. Or maybe somehow it could be due to our excessive humidity here in Louisiana. I do leave them to cool in the hood. I have also tried leaving them in the cooker overnight. It's an excessive amount of condensation. To the point that it pools on top of the media and drowns the explant if I don't deal with it. I switched to gellan gum about a year ago. I like that you can spot contamination quicker with it.
User avatar
By RadRiverOtter
Location: 
Posts:  25
Joined:  Mon Nov 09, 2020 12:43 am
#416543
I think I might have figured out the issue. I am just not sure how to solve it. My pressure cooker actually operates at 17psi instead of 15psi, resulting in higher than 240° temps. This could be because I live below sea level or faulty hardware. I am ordering a new weight and pressure gauge just in case they are faulty. If they are not, I guess I need to drill some of the weight out to make up for the extra pressure.
Rhizome healthy?

I don't have a great reference for the firmness. I[…]

zeeth.png This is that definitely-not-a-Moon-Tr[…]

But I thought that there are no subtropical threa[…]

Maybe just Sarranoia

No idea, but I'd think any pest that feeds on the […]

SASE received. Order is fulfilled. Return envelope[…]

SASE received. Order is fulfilled. Return envelope[…]

SASE received. Order is fulfilled. Return envelope[…]

SASE received. Order is fulfilled. Return envelope[…]

Support the community - Shop at FlytrapStore.com!